GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
OCS_FC(4) FreeBSD Kernel Interfaces Manual OCS_FC(4)

ocs_fc
Device driver for Emulex Fibre Channel Host Adapters

To compile this driver into the kernel, add this line to the kernel configuration file:
device ocs_fc

To load the driver as a module at boot, add this line to loader.conf(5):

ocs_fc_load="YES"

The ocs_fc driver provides access to Fibre Channel SCSI devices.

The ocs_fc driver supports initiator and target modes. Support is available for Arbitrated loops, Point-to-Point, and Fabric connections. FC-Tape is highly recommended for connections to tape drives that support it. FC-Tape includes four elements from the T-10 FCP-4 specification:

  • Precise Delivery of Commands
  • Confirmed Completion of FCP I/O Operations
  • Retransmission of Unsuccessfully Transmitted IUs
  • Task Retry Identification

Together these features allow for link level error recovery with tape devices. Without link level error recovery, an initiator cannot, for instance, tell whether a tape write command that has timed out resulted in all, part, or none of the data going to the tape drive. FC-Tape is automatically enabled when both the controller and target support it.

The ocs_fc driver supports these Fibre Channel adapters:
Emulex 16/8G FC GEN 5 HBAS
LPe15004 FC Host Bus Adapters
LPe160XX FC Host Bus Adapters
    
Emulex 32/16G FC GEN 6 HBAS
LPe3100X FC Host Bus Adapters
LPe3200X FC Host Bus Adapters
    
Emulex 64/32G FC GEN 7 HBAS
LPe3500X FC Host Bus Adapters
    

Adapter firmware updates are persistent.

Firmware can be updated by following these steps:

  1. Copy this code to a Makefile:
    KMOD=ocsflash
    FIRMWS=imagename.grp:ocsflash
    .include <bsd.kmod.mk>
        
  2. Replace imagename with the name of the GRP file.
  3. Copy the Makefile and GRP file to a local directory
  4. Execute make and copy the generated ocsflash.ko file to /lib/modules
  5. Check kernel messages regarding status of the operation
  6. Reboot the machine

Options are controlled by setting values in /boot/device.hints.

They are:

hint.ocs_fc.N.initiator
Enable initiator functionality. Default 1 (enabled), 0 to disable.
hint.ocs_fc.N.target
Enable target functionality. Default 1 (enabled), 0 to disable.
hint.ocs_fc.N.topology
Topology: 0 for Auto, 1 for NPort only, 2 for Loop only.
hint.ocs_fc.N.speed
Link speed in megabits per second. Possible values include: 0 Auto-speed negotiation (default), 4000 (4GFC), 8000 (8GFC), 16000 (16GFC).

dev.ocs_fc.N.port_state
Port state (read/write). Valid values are online and offline.
dev.ocs_fc.N.wwpn
World Wide Port Name (read/write).
dev.ocs_fc.N.wwnn
World Wide Node Name (read/write).
dev.ocs_fc.N.fwrev
Firmware revision (read-only).
dev.ocs_fc.N.sn
Adapter serial number (read-only).
dev.ocs_fc.N.configured_speed
Configured Port Speed (read/write). Valid values are: 0 Auto-speed negotiation (default), 4000 (4GFC), 8000 (8GFC), 16000 (16GFC).
dev.ocs_fc.N.configured_topology
Configured Port Topology (read/write). Valid values are: 0-Auto; 1-NPort; 2-Loop.
dev.ocs_fc.N.current_speed
Current Port Speed (read-only).
dev.ocs_fc.N.current_topology
Current Port Topology (read-only).

For general information and support, go to the Broadcom website at: http://www.broadcom.com/ or E-Mail at ocs-driver-team.pdl@broadcom.com.

ifconfig(8)

The ocs_fc driver was written by Broadcom.
December 29, 2021 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.