GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PPI(4) FreeBSD Kernel Interfaces Manual PPI(4)

ppi
user-space interface to ppbus parallel 'geek' port

device ppi

Minor numbering: unit numbers correspond directly to ppbus numbers.


#include <dev/ppbus/ppi.h>
#include <dev/ppbus/ppbconf.h>

The ppi driver provides a convenient means for user applications to manipulate the state of the parallel port, enabling easy low-speed I/O operations without the security problems inherent with the use of the /dev/io interface.

All I/O on the ppi interface is performed using ioctl() calls. Each command takes a single uint8_t argument, transferring one byte of data. The following commands are available:
, PPISDATA
Get and set the contents of the data register.
, PPISSTATUS
Get and set the contents of the status register.
, PPISCTRL
Get and set the contents of the control register. The following defines correspond to bits in this register. Setting a bit in the control register drives the corresponding output low.
 
 
 
 
 
, PPISEPP
Get and set the contents of the EPP control register.
, PPISECR
Get and set the contents of the ECP control register.
, PPISFIFO
Read and write the ECP FIFO (8-bit operations only).

To present the value 0x5a to the data port, drive STROBE low and then high again, the following code fragment can be used:

	int		fd;
	uint8_t		val;

	val = 0x5a;
	ioctl(fd, PPISDATA, &val);
	ioctl(fd, PPIGCTRL, &val);
	val |= STROBE;
	ioctl(fd, PPISCTRL, &val);
	val &= ~STROBE;
	ioctl(fd, PPISCTRL, &val);

The inverse sense of signals is confusing.

The ioctl() interface is slow, and there is no way (yet) to chain multiple operations together.

The headers required for user applications are not installed as part of the standard system.

January 2, 1998 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.