GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
NG_HOLE(4) FreeBSD Kernel Interfaces Manual NG_HOLE(4)

ng_hole
netgraph discard node type

#include <sys/types.h>
#include <netgraph/ng_hole.h>

The hole node type silently discards all data and control messages it receives. This type is used for testing and debugging.

A ng_hole node accepts any request to connect, regardless of the hook name, as long as the name is unique.

This node type supports the generic control messages, plus the following:
(getstats)
This command takes an ASCII string argument, the hook name, and returns the statistics associated with the hook as a struct ng_hole_hookstat.
(clrstats)
This command takes an ASCII string argument, the hook name, and clears the statistics associated with the hook.
(getclrstats)
This command is identical to NGM_HOLE_GET_STATS, except that the statistics are also atomically cleared.

This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.

netgraph(4), ng_echo(4), ngctl(8)

The ng_hole node type was implemented in FreeBSD 4.0.

Julian Elischer <julian@FreeBSD.org>
May 19, 2004 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.