GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
NG_TEE(4) FreeBSD Kernel Interfaces Manual NG_TEE(4)

ng_tee
netgraph ``tee'' node type

#include <sys/types.h>
#include <netgraph/ng_tee.h>

The tee node type has a purpose similar to the tee(1) command. Tee nodes are useful for debugging or “snooping” on a connection between two netgraph nodes. Tee nodes have four hooks, right, left, right2left, and left2right. All data received on right is sent unmodified to both hooks left and right2left. Similarly, all data received on left is sent unmodified to both right and left2right.

Packets may also be received on right2left and left2right; if so, they are forwarded unchanged out hooks right and left, respectively.

This node type supports the following hooks:
right
The connection to the node on the right.
left
The connection to the node on the left.
right2left
Tap for right to left traffic.
left2right
Tap for left to right traffic.

This node type supports the generic control messages, plus the following.
(getstats)
Get statistics, returned as a struct ng_tee_stats.
(clrstats)
Clear statistics.

This node shuts down upon receipt of an NGM_SHUTDOWN control message, or when all hooks have been disconnected. If both right and left hooks are present, node removes itself from the chain gently, connecting right and left together.

tee(1), netgraph(4), ngctl(8)

The ng_tee node type was implemented in FreeBSD 4.0.

Julian Elischer <julian@FreeBSD.org>
May 28, 2004 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 4 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.