GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUF_LOCKFREE(9) FreeBSD Kernel Developer's Manual BUF_LOCKFREE(9)

BUF_LOCKFREE
destroys a buffer's lock

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/uio.h>
#include <sys/bio.h>
#include <sys/buf.h>

void
BUF_LOCKFREE(struct buf *bp);

The BUF_LOCKFREE() macro destroys the buffer lock. The lock must not be held when this macro is called or a panic will result.

Its argument is:

bp
The buffer whose lock is to be destroyed.

buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockdestroy(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 9, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.