GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUS_GENERIC_ATTACH(9) FreeBSD Kernel Developer's Manual BUS_GENERIC_ATTACH(9)

bus_generic_attach
generic implementation of DEVICE_ATTACH for buses

#include <sys/param.h>
#include <sys/bus.h>

int
bus_generic_attach(device_t dev);

This function provides an implementation of the DEVICE_ATTACH(9) method which can be used by most bus code. It simply calls device_probe_and_attach(9) for each child device attached to the bus.

Zero is returned on success, otherwise an appropriate error is returned.

device(9), driver(9)

This manual page was written by Doug Rabson.
January 15, 2017 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.