GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUS_GET_RESOURCE(9) FreeBSD Kernel Developer's Manual BUS_GET_RESOURCE(9)

bus_get_resource
read a resource range/value with a given resource ID

#include <sys/param.h>
#include <sys/bus.h>
#include <sys/rman.h>

int
bus_get_resource(device_t dev, int type, int rid, rman_res_t *startp, rman_res_t *countp);

The bus_get_resource() function reads the range or value of the resource type, rid pair and stores it in the startp and countp arguments.

The arguments are as follows:

dev
The device to read the resource from.
type
The type of resource you want to read. It is one of:

for IRQs
for ISA DMA lines
for I/O memory
for I/O ports
rid
A bus-specific handle that identifies the resource being read.
startp
A pointer to the start address of this resource.
countp
A pointer to the length of the resource. For example, the size of the memory in bytes.

Zero is returned on success, otherwise an error is returned.

bus_set_resource(9), device(9), driver(9)

This manual page was written by Sascha Wildner.
September 26, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.