GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
CR_CANSEE(9) FreeBSD Kernel Developer's Manual CR_CANSEE(9)

cr_cansee
determine visibility of objects given their user credentials

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/ucred.h>

int
cr_cansee(struct ucred *u1, struct ucred *u2);

This function determines the visibility of objects in the kernel based on the real user IDs and group IDs in the credentials u1 and u2 associated with them.

The visibility of objects is influenced by the sysctl(8) variables security.bsd.see_other_gids and security.bsd.see_other_uids, as per the description in cr_seeothergids(9) and cr_seeotheruids(9) respectively.

This function returns zero if the object with credential u1 can “see” the object with credential u2, or ESRCH otherwise.

[]
The object with credential u1 cannot “see” the object with credential u2.
[]
The object with credential u1 has been jailed and the object with credential u2 does not belong to the same jail as u1.
[]
The MAC subsystem denied visibility.

cr_seeothergids(9), cr_seeotheruids(9), mac(9), p_cansee(9)
November 19, 2006 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.