GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
HEXDUMP(9) FreeBSD Kernel Developer's Manual HEXDUMP(9)

hexdump
dump a block of bytes to the console in hexadecimal form

#include <sys/systm.h>

void
hexdump(void *ptr, int length, const char *hdr, int flags);

The hexdump() function prints an array of bytes to the console in hexadecimal form, along with the ASCII representation of the bytes, if possible. By default, each line of output will start with an offset count, followed by 16 hexadecimal values, followed by 16 ASCII characters.
ptr
Pointer to the array of bytes to print. It does not need to be NUL-terminated.
length
Number of bytes to print.
hdr
Pointer to a NUL-terminated character string that will be prepended to each line of output. A value of NULL implies that no header will be printed.
flags
Flags for controlling the formatting of the output.
Bits 0-7
Integer value of the number of bytes to display on each line. A value of 0 implies that the default value of 16 will be used.
Bits 8-15
Character ASCII value to use as the separator for the hexadecimal output. A value of 0 implies that the default value of 32 (ASCII space) will be used.
Do not print the offset column at the beginning of each line.
Do not print the hexadecimal values on each line.
Do not print the character values on each line.

ascii(7)

This manual page was written by Scott Long.
December 7, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.