GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
SYSCALL_MODULE(9) FreeBSD Kernel Developer's Manual SYSCALL_MODULE(9)

SYSCALL_MODULE
syscall kernel module declaration macro

#include <sys/param.h>
#include <sys/kernel.h>
#include <sys/proc.h>
#include <sys/module.h>
#include <sys/sysent.h>

SYSCALL_MODULE(name, int *offset, struct sysent *new_sysent, modeventhand_t evh, void *arg);

The SYSCALL_MODULE() macro declares a new syscall. SYSCALL_MODULE() expands into a kernel module declaration with name ‘sys/name’.

The rest of the arguments expected by this macro are:

offset
A pointer to an int which saves the offset in struct sysent where the syscall is allocated. If the location pointed to by offset holds a non 0 number it will be used if possible. If it holds 0 then one will be assigned.
new_sysent
is a pointer to a structure that specifies the function implementing the syscall and the number of arguments this function needs (see <sys/sysent.h>).
evh
A pointer to the kernel module event handler function with the argument arg. Please refer to module(9) for more information.
arg
The argument passed to the callback functions of the evh event handler when it is called.

The syscall number assigned to the module can be retrieved using the modstat(3) and modfind(3) library functions in libc. The MACRO SYSCALL_MODULE_HELPER() includes SYSCALL_MODULE() and much of its boilerplate code.

A minimal example for a syscall module can be found in /usr/share/examples/kld/syscall/module/syscall.c.

module(9)

/usr/share/examples/kld/syscall/module/syscall.c

This manual page was written by Alexander Langer <alex@FreeBSD.org>.
January 24, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.