GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_SET(9) FreeBSD Kernel Developer's Manual VFS_SET(9)

VFS_SET
set up loadable file system vfsconf

#include <sys/param.h>
#include <sys/kernel.h>
#include <sys/module.h>
#include <sys/mount.h>

void
VFS_SET(struct vfsops *vfsops, fsname, int flags);

VFS_SET() creates a vfsconf structure for the loadable module with the given vfsops, fsname and flags, and declares it by calling DECLARE_MODULE(9) using vfs_modevent() as the event handler.

Possible values for the flags argument are:

File system should be statically available in the kernel.
Network exportable file system.
Does not support write operations.
Pseudo file system, data does not represent on-disk files.
Loopback file system layer.
File names are stored as Unicode.
Can be mounted from within a jail if allow.mount and allow.mount.<fsname> jail parameters are set.
Supports delegated administration if vfs.usermount sysctl is set to 1.
When in VFS method, the thread suspension is deferred to the user boundary upon arrival of stop action.

/*
 * Fill in the fields for which we have special methods.
 * The others are initially null.  This tells vfs to change them to
 * pointers to vfs_std* functions during file system registration.
 */
static struct vfsops myfs_vfsops = {
        .vfs_mount =    myfs_mount,
        .vfs_root =     myfs_root,
        .vfs_statfs =   myfs_statfs,
        .vfs_unmount =  myfs_unmount,
};

VFS_SET(myfs_vfsops, myfs, 0);

jail(2), jail(8), DECLARE_MODULE(9), vfs_modevent(9), vfsconf(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
August 16, 2018 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.