GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_SYNC(9) FreeBSD Kernel Developer's Manual VFS_SYNC(9)

VFS_SYNC
flush unwritten data

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_SYNC(struct mount *mp, int waitfor);

The VFS_SYNC() macro writes out all unwritten data in the file system mounted as mp.

The arguments it expects are:

mp
The file system.
waitfor
Whether the function should wait for I/O to complete. Possible values are:
synchronously wait for I/O to complete
start all I/O, but do not wait for it
push data not written by file system syncer

The VFS_SYNC() macro calls the vfs_sync method of the file system, which normally calls VOP_FSYNC(9) for all the vnodes in the file system.

fsync(2), sync(2), VFS(9), vnode(9), VOP_FSYNC(9)

This manual page was written by Doug Rabson.
May 23, 2009 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.