GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_MAP_SYNC(9) FreeBSD Kernel Developer's Manual VM_MAP_SYNC(9)

vm_map_sync
push dirty pages to their pager

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_map.h>

int
vm_map_sync(vm_map_t map, vm_offset_t start, vm_offset_t end, boolean_t syncio, boolean_t invalidate);

The vm_map_sync() function forces any dirty cached pages in the range start to end within the map to be pushed to their underlying pager.

If syncio is TRUE, dirty pages are written synchronously.

If invalidate is TRUE, any cached pages are also freed.

The range provided must be contiguous, it MUST NOT contain holes. The range provided MUST NOT contain any sub-map entries.

The vm_map_sync() function returns KERN_SUCCESS if successful.

Otherwise, KERN_INVALID_ADDRESS will be returned if the function encountered a sub-map entry; KERN_INVALID_ARGUMENT will be returned if the function encountered a hole in the region provided, or if an entry could not be found for the given start address.

vm_map(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 9, 2011 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.