GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_SET_PAGE_SIZE(9) FreeBSD Kernel Developer's Manual VM_SET_PAGE_SIZE(9)

vm_set_page_size
initialize the system page size

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>

void
vm_set_page_size(void);

The vm_set_page_size() function initializes the system page size. If vm_cnt.v_page_size (see <sys/vmmeter.h>) equals 0, PAGE_SIZE is used; otherwise, the value stored in vm_cnt.v_page_size is used. If vm_cnt.v_page_size is not a power of two, the system will panic.

vm_set_page_size() must be called prior to any page size dependent functions.

This manual page was written by Chad David <davidc@acns.ab.ca>.
March 21, 2014 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.