GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_ADVISE(9) FreeBSD Kernel Developer's Manual VOP_ADVISE(9)

VOP_ADVISE
apply advice about use of file data

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_ADVISE(struct vnode *vp, off_t start, off_t end, int advice);

This call applies advice for a range of a file's data. It is used to implement the posix_fadvise system call.

Its arguments are:

vp
The vnode of the file.
start
The start of the range of file data.
end
The end of the range of file data. A value of OFF_MAX indicates that the advice is to be applied up to the end of the file.
advice
The type of operation to apply to the file data. Possible values are:
Initiate an asynchronous read of the file data if it is not already resident.
Decrease the in-memory priority of clean file data or discard clean file data.

If the start and end offsets are both zero, then the operation should be applied to the entire file. Note that this call is advisory only and may perform the requested operation on a subset of the requested range (including not performing it at all) and still return success.

The file should be unlocked on entry.

Zero is returned if the call is successful, otherwise an appropriate error code is returned.

[]
An invalid value was given for advice.

vnode(9)
September 26, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.