GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_LINK(9) FreeBSD Kernel Developer's Manual VOP_LINK(9)

VOP_LINK
create a new name for a file

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_LINK(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);

This links a new name in the specified directory to an existing file.

Its arguments are:

dvp
The vnode of the directory.
vp
The vnode of the file to be linked.
cnp
Pathname information about the file.

The pathname info should not be released on exit because it is done by the caller. The directory and file vnodes should not be released on exit.

VOP_LINK() expects the directory and file vnodes to be locked on entry and will leave the vnodes locked on return.

Zero is returned if the file was linked successfully, otherwise an error is returned.

[]
The file has too many links.
[]
The file is immutable.
[]
A hard link is not possible between different file systems.

vn_lock(9), vnode(9)

This manual page was originally written by Doug Rabson.
July 24, 1996 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.