GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_READLINK(9) FreeBSD Kernel Developer's Manual VOP_READLINK(9)

VOP_READLINK
read the target of a symbolic link

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/uio.h>

int
VOP_READLINK(struct vnode *vp, struct uio *uio, struct ucred *cred);

This reads the target pathname of a symbolic link
vp
The vnode of the symlink.
uio
The location of the data to be read or written.
cred
The credentials of the caller.

The vnode should be locked on entry and will still be locked on exit.

Zero is returned on success, otherwise an error code is returned.

[]
A read error occurred while reading the contents of the symlink.
[]
Corrupted data was detected while reading the contents of the symlink.

uiomove(9), vnode(9)

This manual page was written by Doug Rabson.
March 30, 2020 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.