GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_REMOVE(9) FreeBSD Kernel Developer's Manual VOP_REMOVE(9)

VOP_REMOVE, VOP_RMDIR
remove a file or directory

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_REMOVE(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);

int
VOP_RMDIR(struct vnode *dvp, struct vnode *vp, struct componentname *cnp);

These entry points remove files and directories respectively.

The arguments are:

dvp
The vnode of the directory.
vp
The vnode of the file to be removed.
cnp
Pathname information about the file.

Both dvp and vp should be locked on entry and remain locked on return.

Zero is returned on success, otherwise an error code is returned.

[]
The file is immutable.
[]
An attempt was made to remove a directory which is not empty.

vnode(9), VOP_LOOKUP(9)

This manual page was written by Doug Rabson.
July 24, 1996 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.