GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEV_CLONE(9) FreeBSD Kernel Developer's Manual DEV_CLONE(9)

dev_clone, drain_dev_clone_events
eventhandler for name-based device cloning in devfs

#include <sys/param.h>
#include <sys/conf.h>

void
clone_handler(void *arg, struct ucred *cr, char *name, int namelen, struct cdev **dev);

EVENTHANDLER_REGISTER(dev_clone, clone_handler, arg, priority);

void
drain_dev_clone_events();

A device driver may register a listener that will be notified each time a name lookup on the devfs(5) mount point fails to find the vnode. A listener shall be registered for the dev_clone event. When called, it is supplied with the first argument arg that was specified at handler registration time, appropriate credentials cr, and a name name of length namelen that we look for. If the handler decides that the name is appropriate and wants to create the device that will be associated with the name, it should return it to devfs in the dev argument.

The drain_dev_clone_events() function is a barrier. It is guaranteed that all calls to eventhandlers for dev_clone that were started before drain_dev_clone_events() call, are finished before it returns control.

devfs(5), namei(9)
January 3, 2009 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.