GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_ENABLE(9) FreeBSD Kernel Developer's Manual DEVICE_ENABLE(9)

device_enable, device_disable, device_is_enabled
manipulate device enabled flag

#include <sys/param.h>
#include <sys/bus.h>

void
device_enable(device_t dev);

void
device_disable(device_t dev);

int
device_is_enabled(device_t dev);

Each device has an enabled flag associated with it. A device is enabled by default when it is created but may be disabled (for instance to prevent a destructive or time consuming probe attempt). To disable a device, call device_disable(), to re-enable it, call device_enable() and to test to see if a device is enabled, call device_is_enabled().

device(9)

This manual page was written by Doug Rabson.
June 16, 1998 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.