GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PANIC(9) FreeBSD Kernel Developer's Manual PANIC(9)

panic
bring down system on fatal error

#include <sys/types.h>
#include <sys/systm.h>

void
panic(const char *fmt, ...);

void
vpanic(const char *fmt, va_list ap);

The panic() and vpanic() functions terminate the running system. The message fmt is a printf(3) style format string. The message is printed to the console and the location panicstr is set to the address of the message text for retrieval from the OS core dump.

If the kernel debugger is installed control is passed to it, otherwise an attempt to save a core dump of the OS to a configured dump device is made.

If panic() is called twice (from the disk sync routines, for example) the system is rebooted without syncing the disks.

The panic() function does not return.
April 23, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.