GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
RESOURCE_INT_VALUE(9) FreeBSD Kernel Developer's Manual RESOURCE_INT_VALUE(9)

resource_int_value, resource_long_value, resource_string_value
get a value from the hints mechanism

#include <sys/param.h>
#include <sys/bus.h>

int
resource_int_value(const char *name, int unit, const char *resname, int *result);

int
resource_long_value(const char *name, int unit, const char *resname, long *result);

int
resource_string_value(const char *name, int unit, const char *resname, const char **result);

These functions fetch a value from the “hints” mechanism.

The functions take the following arguments:

name
The name of the device to get the resource value from.
unit
The unit number of the device. -1 is special and is used for wildcard entries.
resname
The resource name.
result
A pointer to memory in which to store the resource value.

If successful, the functions return 0. Otherwise, a non-zero error code is returned.

The functions will fail if:
[]
The resource could not be found.
[]
Inappropriate resource type.

device(9), driver(9)

This manual page was written by Warner Losh <imp@FreeBSD.org>.
March 1, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.