GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VGONE(9) FreeBSD Kernel Developer's Manual VGONE(9)

vgone
prepare a vnode for reuse

#include <sys/param.h>
#include <sys/vnode.h>

void
vgone(struct vnode *vp);

The vgone() function prepares the vnode to be destroyed. The preparation includes the cleaning of all file system specific data and the removal from its mount point vnode list.

If the vnode has a v_usecount of zero, and its VIRF_DOOMED flag is not set, it is moved to the head of the free list as in most cases the vnode is about to be reused, or its file system is being unmounted.

The vgone() function takes an exclusively locked vnode, and returns with the vnode exclusively locked.

vnode(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
December 8, 2019 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.