GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_PAGE_DONTNEED(9) FreeBSD Kernel Developer's Manual VM_PAGE_DONTNEED(9)

vm_page_dontneed
indicate that a page is not needed anymore

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>

void
vm_page_dontneed(vm_page_t m);

The vm_page_dontneed() function advises the VM system that the given page is no longer required. If the page is already in the inactive queue or in the cache queue, this function does nothing; otherwise the page is deactivated.

Note that vm_page_dontneed() does not necessarily deactivate a page, but instead implements an algorithm that attempts to prevent small objects from having their pages reused too quickly, and large objects from flushing smaller ones from the queues as their pages are released.

vm_page_deactivate(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 30, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.