GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VSLOCK(9) FreeBSD Kernel Developer's Manual VSLOCK(9)

vslock, vsunlock
lock/unlock user space addresses in memory

#include <sys/param.h>
#include <sys/proc.h>
#include <vm/vm.h>
#include <vm/vm_extern.h>

int
vslock(void *addr, size_t len);

void
vsunlock(void *addr, size_t len);

The vslock() and vsunlock() functions respectively lock and unlock a range of addresses belonging to the currently running process into memory. The actual amount of memory locked is a multiple of the machine's page size. The starting page number is computed by truncating addr to the nearest preceding page boundary, and by rounding up addr + len to the next page boundary. The process context to use for this operation is taken from the global variable curproc.

The vslock() function will return 0 on success, otherwise it will return one of the errors listed below.

The vslock() function will fail if:
[]
The addr and len parameters specify a memory range that wraps around the end of the machine address space.
[]
The size of the specified address range exceeds the system limit on locked memory.
[]
Some portion of the indicated address range is not allocated. There was an error faulting/mapping a page.
August 29, 2012 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.