|
|
| |
XINE(5) |
FreeBSD File Formats Manual |
XINE(5) |
xine - a free video player
MRLs are similar to URLs in your web browser. They describe the media to read
from. Valid MRLs may be plain file names or one of the following (see also the
notes below):
- • Filesystem:
-
file:<path>
fifo:<path>
stdin:/
- • CD and DVD:
-
dvd:/[device_name][/title[.part]]
dvd:/DVD_image_file[/title[.part]]
dvd:/DVD_directory[/title[.part]]
(use the path of the directory which contains VIDEO_TS)
vcd://[CD_image_or_device_name][@[letter]number]
vcdo://track_number
cdda:/[device][/track_number]
- • Video devices:
-
v4l://[tuner_device/frequency]
v4l2://tuner_device
dvb://channel_number
(nth channel in your channels.conf)
dvb://channel_name
dvbc://channel_name:tuning_parameters
dvbs://channel_name:tuning_parameters
dvbt://channel_name:tuning_parameters
dvba://channel_name:tuning_parameters
pvr:/tmp_files_path!saved_files_path!max_page_age
(for WinTV PVR 250 and 350)
- • Network:
-
http://host...
tcp://host[:port]
udp://host[:port[?iface=interface]]
rtp://host[:port[?iface=interface]]
(default port for tcp, udp and rtp is 7658)
smb://...
mms://host...
pnm://host...
rtsp://host... (requires Real codecs)
Additional input plugins will provide additional MRL types. The
ones listed above are available with stock libxine.
NOTE: where a file name is required, the full path must
be provided - from a shell, you can normally use
"$PWD/file" or "$(pwd)/file" or
"`pwd`/file" if the file is in the current directory.
(Which one depends on your shell; all three work in bash. Also, normal URL
encoding rules apply; `%', in particular, must be encoded as `%25'.)
As of xine-lib 1.1.3, the DVD title number may be 0 (select
navigation) and the chapter number may be 0 (full title).
A simple vcd:/ runs the default item (e.g. perhaps track 1 or entry 0)
using the default VCD device (perhaps /dev/cdrom). Both the default item and
default device are user-configurable.
It is however also possible to specify both Video CD
device/filename and item explicitly in the MRL.
For example vcd:/dev/dvd specifies the default entry using
device /dev/dvd which might useful if this is your DVD which is different
than your CD-ROM device and your DVD drive can play CD's. And
vcd://test_svcd_ntsc.cue specifies the cue file for CD image on disk.
(test_svcd_ntsc.bin is the corresponding bin file, but using that won't
work.)
After the optional device name or file name, you can name the kind
of unit, preceded by a colon. An MRL which ends in a colon is like not
adding it at all: the default entry type and number is used. Items come in 4
flavours: "Track", "Entry",
"Playback" and "Segment". These units are
indicated with the capital first letter of each type: T, E,
P, S, s. An uppercase S in the MRL display
indicates a NTSC segment while a lowercase s indicates a PAL segment.
However, when you enter an MRL, the case of these letters is
insignificant.
Depending on the Video CD, you might not have any playable
segments (S,s) or playback control (P). If you give a
MRL that refers to a playback control entry but there is no playback
control, your playback number will silently be converted into the
corresponding entry number.
You can configure various things that affect MRLs are selected
when there is some ambiguity in the MRL name. media.vcd.autoplay sets
what kind of unit to to use in a MRL is none is given. Another configuration
setting, vcd.device, determines what device to use if that part is
not given. When you hit the VCD button, that is equivalent to entering
vcd:/ and thus these two configuration settings are used to expand
the MRL.
Some examples of MRLs are given below. In the examples, we assume
the following configuration settings:
- vcd://
- Play (navigate) default item (in this case Entry ID 0) from the default
device (in this case set to /dev/cdrom)
- vcd://@
- Same as above
- vcd:///dev/cdrom@
- Same effect as above since the default device is set to /dev/cdrom.
- vcd:///dev/cdrom@E0
- Same as above. But note that this is because we have autoplay:entry which
is no longer the default value.
- vcd:///dev/cdrom2@
- Play (navigate) the default item of /dev/cdrom2
- vcd:///dev/cdrom2
- should be same as above but is currently broken?
- vcd:///dev/cdrom2@T1
- Play Track 1 from /dev/cdrom2
- vcd:///dev/cdrom@S1
- Play segment 1 from /dev/cdrom. This assumes that there *is* a segment 1.
Check the MRL list to see if that is the case.
- vcd://@P1
- Play playlist item 1 from default device. If there is no playback control,
the MRL will be converted into vcd:/@E0. Again check the MRL list to see
if there is a P1.
- vcd://@P1*
- Probably same as above.
- vcd:///dev/cdrom@E1
- Play Entry id 1 from default device.
- vcd://@S0
- Play segment 0 from default device.
- vcd://@3
- Play track 3 from default device.
- vcd:///dev/cdrom2:1
- Play track 1 from /dev/cdrom2.
- vcd:///tmp/ntsc.cue@
- Play default item (E0) of /tmp/ntsc.bin. Note trailing @.
- vcd://ntsc.cue/@E0
- Play entry 0 of ntsc.bin.
- vcd:///tmp/ntsc.nrg/@E0
- Play entry 0 of /tmp/ntsc.nrg (Nero file). Works for some simple Nero
images.
DVB MRLs require that xine-lib/channels.conf exists in $XDG_CONFIG_HOME/ or
~/.config/ and contains valid data. This can be obtained by generating a
tuning file using the LinuxTV DVB apps utility "scan" (or
"dvbscan" if you're using a version newer than 1.1.0):
scan -o zap
/usr/share/doc/dvb-utils/examples/scan/dvb-t/uk-PontopPike
>~/.config/xine-lib/channels.conf
(This example is for the writer's local transmitter, using a file
from the Debian dvb-utils package.)
For the dvbc, dvbs and dvbt MRLs, tuning parameters are expected,
taking one of the following forms:
- DVB-S
- <frequency>:<polarisation>:<sat-no>:<sym-rate>:<vpid>:<apid>:<service-id>
- DVB-C
- <frequency>:<inversion>:<sym-rate>:<fec>:<qam>:<vpid>:<apid>:<service-id>
- DVB-T
- <frequency>:<inversion>:<bw>:<fec-hp>:<fec-lp>:<qam>:<transmission-mode>:<guardlist>:<hierarchy-info>:<vpid>:<apid>:<service-id>
- DVB-A
- <frequency>:<qam>:<vpid>:<apid>:<service-id>
The individual parameters are:
- frequency
- number, usually in kHz
- polarisation
- `v' or `h'
- sat-no
- unsigned long, usually 0
- sym-rate
- symbol rate in MSyms/sec
- inversion
- INVERSION_ON, INVERSION_OFF, INVERSION_AUTO
- fec, fec-hp, fec-lp
- FEC_1_2, FEC_2_3, FEC_3_4 ... FEC_8_9, FEC_AUTO, FEC_NONE
- qam
- QPSK, QAM_128, QAM_16 ...
- bw
- BANDWIDTH_6_MHZ, BANDWIDTH_7_MHZ, BANDWIDTH_8_MHZ
- transmission-mode
- TRANSMISSION_MODE_2K, TRANSMISSION_MODE_8K
- guardlist
- GUARD_INTERVAL_1_4, GUARD_INTERVAL_1_8, GUARD_INTERVAL_1_16,
GUARD_INTERVAL_1_32,
- hierarchy-info
- HIERARCHY_1, HIERARCHY_2, HIERARCHY_4, HIERARCHY_NONE
- vpid
- video program ID
- apid
- audio program ID
- service-id
- service ID (needed for now/next information etc.)
The following keyboard & mouse inputs may be accepted:
- Menu 2
- Start/stop recording
- Menu 3
- Toggle zoom
- Menu 7
- Toggle now/next display
- Previous/Next Chapter
- Previous/next channel
- Mouse wheel & button 1
- Scroll through channel list & select the highlighted channel
external subtitle files (any mrl)
Text subtitle files may be appended to the MRL:.
- <mrl>#subtitle:<subtitlefile>
- This is the normal way to define the subtitle file to use. The frontend
will not take any notice of the subtitle file. For example:
file://home/user/wibble.mpg#subtitle:/home/user/wibble.sub
(Note that some front ends can detect subtitles files where the name differs
as shown in the example.)
After a delimiting # you can add several stream parameters:
- novideo
- Video will be ignored.
- noaudio
- Audio will be ignored.
- nospu
- Subpictures will be ignored.
- demux:<demux name>
- Specify the demux plugin to use.
- volume:<level>
- Set audio volume.
- compression:<level>
- Set audio dynamic range compression.
- <config entry>:<config value>
- Assign a new value to any config entry.
- save:<file>
- Save the stream (if allowed) to the named file, relative to the directory
given by the option "media.capture.save_dir".
- change configuration option 'on the fly':
-
You can change a configuration option at any time, using the special
cfg:/ MRL style. The syntax is:
cfg:/<config entry> : <config value>
Unlike stream config option, you can change anything before playing
the stream.
xine(1), aaxine(1), gxine(1), toxine(1),
totem(1), kaffeine(1) ...
The programs are documented fully on the xine home page:
http://www.xine-project.org/
This text was extracted from the xine man page by Darren Salt
<dsalt@users.sourceforge.net>. The xine man page was written by Siggi
Langauf <siggi@debian.org> for the xine project. Lots of additions by
Guenter Bartsch <guenter@users.sourceforge.net>, Daniel Caujolle-Bert
<f1rmb@users.sourceforge.net>, Rocky Bernstein <rocky@panix.com>,
and Philipp Hahn <pmhahn@users.sourceforge.net>.
Visit the GSP FreeBSD Man Page Interface. Output converted with ManDoc. |