|
|
| |
EXTIPL(8) |
FreeBSD System Manager's Manual |
EXTIPL(8) |
extipl - a partition-selectable boot loader/installer for IBM-PC compatible
computers.
extipl subcommand arguments ...
This manual page describes briefly the extipl command.
extipl stands for "Extended IPL". That is an IBM's
HD-IPL compatible boot strap code for IBM-PC compatible computers. But it
allows to select one of partitions, or one of several BIOS supported HDDs.
extipl is the installer of ExtIPL. This version (v5.0) has 4 IPLs and
three of them now supports the LBA access for large HDD.
- gemini
- The default IPL which has simple GUI-like menu function. The label for
each partition in the 1st HDD can be modified for easy recognition. Delay
for auto-boot also can be changed from 1 to 999, or forever (default is 15
seconds). This also supports the booting from any BIOS supported HDD, and
can change the active partition on the 1st HDD. This IPL actually consists
of two code blocks: pollux (in MBR) and castor (in several sectors
following the MBR). Therefore named after the famous twin in the sky,
Gemini.
- taurus
- The simple IPL which does not have the selector function. It just loads
the OS loader from the active partitions. The difference from the
conventional IPL is the support of LBA access for the large HDD and the
support of booting from logical partitions. This IPL is named after the
zodiac signs followed by gemini.
- aquila
- This IPL can select partitions in the 1st HDD to boot up from. LBA access
and booting from logical partition are supported. Unlike the gemini IPL,
selection menu is much more simple, and can not change the active
partition. The name is taken from the constellation, and the old famous
movie.
- scorpius
- This is the IPL in the old version of extipl. It uses CHS access only,
i.e. does not support LBA access. Selection menu is very simple, but it
does support booting from any BIOS supported HDDs. This name is also taken
from another constellation and the movie.
- save device-filename-of-HD [file]
- Store the current content of MBR in the specified HDD to a file
"filename". Saved content of MBR can be restored by "extipl
restore" described below. If you omit the filename, the default value
"./master.ipl" is used. Back up file is set to be
read-only.
- restore device-filename-of-HD file
- Restore the MBR from the specified file which contains partition
information and the OS booter.
You are asked as:
C)ode: restore ipl code only
T)able: restore partition table only
A)ll: restore ipl code and partition table
restore (c/t/a)?
Reply 'c', 't', or 'a'. It is not examined whether specified
file is valid copy of MBR. Filename cannot be omitted.
- install device-filename-of-HD @IPL_NAME
- Install one of the four Extended-IPL boot code to MBR in the hard disk
specified with the argument device-filename-of-HD. IPL_NAME is one of the
following: gemini, taurus, aquila, and scorpius. The default IPL is
gemini.
Before installation, you are forced to back up MBR to a file,
and are prompted:
Enter file name to save:
If you press <Enter> key only, MBR will be saved into
"./fdiskIPL.<nnn>", where <nnn> is a number from
001 to 999. That number is incremented automatically if that file exists
already.
- fdtest device-filename-of-FD @IPL_NAME
- Install one of the four Extended-IPL boot code to a floppy disk specified
with the argument "device-filename-of-FD." You can't use
Extended-IPL installed floppy for any other purpose. IPL_NAME is one of
the following: gemini, taurus, aquila, and scorpius. The default IPL is
gemini.
This is for testing or trying Extended-IPL, but you can use a
floppy with Extended-IPL to boot your PC if it doesn't boot from hard
disk.
- show device-filename-of-HD
- Display the content of the partition tables in a hard disk specified with
the argument "device-filename-of-HD". The content of an extended
partition is also displayed.
[Example]
# extipl show /dev/hda
=========
Partition TABLE on "/dev/hda"
=========
[1] 0B: MS-Win FAT32 1866MB
[2] 06: DOS FAT16(>32MB) 125MB
A[3] A5: FreeBSD/old NetBSD/386BSD 2596MB
[4] 05: Extended DOS --
( 1) 83: Linux native 256MB
( 2) 83: Linux native 1153MB
( 3) 83: Linux native 86MB
( 4) 82: Linux swap/Solaris x86 62MB
- chgboot device-filename-of-HD
- Change the bootable partition in the specified device interactively. If
you mark an extended partition bootable, you can also mark a partition in
the bootable extended partition bootable.
The follwing keys are understood:
Number : mark the selected partition bootable.
w : write back the modified parition table to the
device.
q : quit without any modification to the device
c : clear the bootable mark.
b : back to the parent partition when you are in an
extended partition. If you are in the top level partition, quit without
any modification.
Please read the documantation for more details.
- clrboot device-filename-of-HD
- marks all partition to be not bootable in a hard disk specified with the
argument "device-filename-of-HD". This force Extended-IPL to
enter partition selection even if shift key is not pressed down. Original
booter in MBR cannot boot OS if all partition is marked non-bootable. You
have to use Extended-IPL to boot something. If BIOS loader of MBR checks
the validity of MBR strictly, it consider the MBR invalid.
In such a case, YOU BECOME UNABLE TO BOOT ANY OS IN YOUR
HARDDISK. BE extremely CAREFUL.
Please read the documantation for more details.
extipl command accepts some option flags for speciallized purpose. Please read
the documentation and the source code for more details.
Options includes:
- -d
- : debug
Option flag for debugging boot code. If you specify this
option, extipl does not install the specified boot code, but writes out
the binary image of boot sector into the file named
"./_BootSec.<nnn>" where <nnn> is the automatic
increment counter.
You can check the content of that image using dump tool or
ndisasm, disassembler for i8086. It may be usefull to improve the boot
code for Extended-IPL or to develop your own IPL code.
- -f
- : force install
This option affects only the subcommand "install".
If you specify this option, extipl does not prompt for the name of
backup file and does not prompt for confirmation of install, but do
write it's IPL boot code into MBR in the specified hard disk silently,
and save the contents of the original MBR into
"./fdiskIPL.<nnn>", where <nnn> is a number from
001 to 999. That number is incremented automatically if that file exists
already.
If you don't need that back up file, please remove it
manually.
- Initial load
- When the boot sequence is started, the string "extipl" is shown
on the screen, and the timer is counting. Default delay for auto startup
is 15 seconds (can be modified from the menu later).
Press <Enter> to boot up from the active partition
immediately. Any other key such as <Space> interrupts this count
down, and the selector menu is displayed.
- Selector Menu
- The selector menu is divided into three parts: top line, lower left, and
lower right. The top line shows the drive to boot from, and the access
mode (LBA/CHS). The lower left area shows the partitions, and the lower
right shows the available commands.
You can use cursor key to select an item from the menu, and
<Enter> decides to execute it. When an extended partiion is
selected, then <Space> key lists the logical partitions in the
selected extended.
- Modification of the waiting delay
- In the Selector Menu of gemini, you can use "<Alt> + t" in
order to modify the waiting delay for auto startup. The unit is second,
and the default is 15 seconds. 0-999 can be entered here, and
"0" means that Selector Menu will be always shown (i.e. no
automatic startup).
- Modification of the partition label
- In the Selector Menu of gemini, you can use "<Alt> + n" in
order to modify the partition label for the 1st HDD. Maximum length of the
label is 20 charaters, and the maximum number of labels is 12. To delete
the registered label, just press <Enter> only after using
"<Alt> + n". <Esc> cancels the current input when
the label is entered.
- Save the current setup for delay and labels
- In the Selector Menu of gemini, you can use "<Alt> + s" in
order to save the modification you done for delay and labels.
taurus IPL can not select partition to boot from. Is just loads the PBR in the
active partition. So nothing special to be done for this.
- Initial load
- To boot up from the active partition, just wait. Nothing to be done. To
show the selector menu, enable <CapsLock> after the BIOS keyboard
initialization. The usage of this menu is similar to the old one, so
please read the description for scorpius below.
- <Shift>
- Extended-IPL loads and runs the boot sector of the first bootable
partition on the first HDD. If shift key is pressed when extended-IPL
booting, it displays a boot selection menu.
- <0>
- Select the other HDD.
- <1>,<2>,<3>,<4>
- Select one of primary/extended/logical partitions of current HDD to load
and run the boot sector in that partition.
- <Enter>
- Load and run the boot sector of selected partition.
- <End>
- Change the bootable flag of selected partition and load and run that boot
sector.
The programs are documented fully at
/usr/local/share/doc/extipl/extipl/English/extipl.txt in English, or
/usr/local/share/doc/extipl/extipl/Japanese/extipl.txt in Japanese.
The author of Extended-IPL is Takamiti Kimura <takamiti@tsden.org>,
English documentation is written by Ryutaroh Matsumoto
<ryutaroh@tsden.org> and distributed as the part of the original source
archive.
This manual page was originally written by Akira YOSHIYAMA
<yosshy@debian.or.jp>, for the Debian GNU/Linux system. Then Taketoshi
Sano <kgh12351@nifty.ne.jp> update the information to match the new
upstream release.
This man page can be freely used by anyone.
Visit the GSP FreeBSD Man Page Interface. Output converted with ManDoc. |