|
|
| |
GRAID(8) |
FreeBSD System Manager's Manual |
GRAID(8) |
graid —
control utility for software RAID devices
graid |
label [-f ]
[-o fmtopt]
[-S size]
[-s strip]
format label
level prov ... |
graid |
add [-f ]
[-S size]
[-s strip]
name label
level |
graid |
delete [-f ]
name [label |
num] |
graid |
insert name
prov ... |
graid |
remove name
prov ... |
graid |
stop [-fv ]
name ... |
The graid utility is used to manage software RAID
configurations, supported by the GEOM RAID class. GEOM RAID class uses on-disk
metadata to provide access to software-RAID volumes defined by different RAID
BIOSes. Depending on RAID BIOS type and its metadata format, different subsets
of configurations and features are supported. To allow booting from RAID
volume, the metadata format should match the RAID BIOS type and its
capabilities. To guarantee that these match, it is recommended to create
volumes via the RAID BIOS interface, while experienced users are free to do it
using this utility.
The first argument to graid indicates an
action to be performed:
label
- Create an array with single volume. The format
argument specifies the on-disk metadata format to use for this array, such
as "Intel". The label argument specifies
the label of the created volume. The level argument
specifies the RAID level of the created volume, such as:
"RAID0", "RAID1", etc. The subsequent list enumerates
providers to use as array components. The special name "NONE"
can be used to reserve space for absent disks. The order of components can
be important, depending on specific RAID level and metadata format.
Additional options include:
-f
- Enforce specified configuration creation if it is officially
unsupported, but technically can be created.
-o
fmtopt
- Specifies metadata format options.
-S
size
- Use size bytes on each component for this
volume. Should be used if several volumes per array are planned, or if
smaller components going to be inserted later. Defaults to size of the
smallest component.
-s
strip
- Specifies strip size in bytes. Defaults to 131072.
add
- Create another volume on the existing array. The
name argument is the name of the existing array,
reported by label command. The rest of arguments are the same as for the
label command.
delete
- Delete volume(s) from the existing array. When the last volume is deleted,
the array is also deleted and its metadata erased. The
name argument is the name of existing array.
Optional label or num
arguments allow specifying volume for deletion.
Additional options include:
-f
- Delete volume(s) even if it is still open.
insert
- Insert specified provider(s) into specified array instead of the first
missing or failed components. If there are no such components, mark
disk(s) as spare.
remove
- Remove the specified provider(s) from the specified array and erase
metadata. If there are spare disks present, the removed disk(s) will be
replaced by spares.
fail
- Mark the given disks(s) as failed, removing from active use unless
absolutely necessary due to exhausted redundancy. If there are spare disks
present - failed disk(s) will be replaced with one of them.
stop
- Stop the given array. The metadata will not be erased.
Additional options include:
-f
- Stop the given array even if some of its volumes are opened.
list
- See
geom(8).
status
- See
geom(8).
load
- See
geom(8).
unload
- See
geom(8).
Additional options include:
-v
- Be more verbose.
The GEOM RAID class follows a modular design, allowing different metadata
formats to be used. Support is currently implemented for the following
formats:
- DDF
- The format defined by the SNIA Common RAID Disk Data Format v2.0
specification. Used by some Adaptec RAID BIOSes and some hardware RAID
controllers. Because of high format flexibility different implementations
support different set of features and have different on-disk metadata
layouts. To provide compatibility, the GEOM RAID class mimics capabilities
of the first detected DDF array. Respecting that, it may support different
number of disks per volume, volumes per array, partitions per disk, etc.
The following configurations are supported: RAID0 (2+ disks), RAID1 (2+
disks), RAID1E (3+ disks), RAID3 (3+ disks), RAID4 (3+ disks), RAID5 (3+
disks), RAID5E (4+ disks), RAID5EE (4+ disks), RAID5R (3+ disks), RAID6
(4+ disks), RAIDMDF (4+ disks), RAID10 (4+ disks), SINGLE (1 disk), CONCAT
(2+ disks).
Format supports two options "BE" and "LE",
that mean big-endian byte order defined by specification (default) and
little-endian used by some Adaptec controllers.
- Intel
- The format used by Intel RAID BIOS. Supports up to two volumes per array.
Supports configurations: RAID0 (2+ disks), RAID1 (2 disks), RAID5 (3+
disks), RAID10 (4 disks). Configurations not supported by Intel RAID BIOS,
but enforceable on your own risk: RAID1 (3+ disks), RAID1E (3+ disks),
RAID10 (6+ disks).
- JMicron
- The format used by JMicron RAID BIOS. Supports one volume per array.
Supports configurations: RAID0 (2+ disks), RAID1 (2 disks), RAID10 (4
disks), CONCAT (2+ disks). Configurations not supported by JMicron RAID
BIOS, but enforceable on your own risk: RAID1 (3+ disks), RAID1E (3+
disks), RAID10 (6+ disks), RAID5 (3+ disks).
- NVIDIA
- The format used by NVIDIA MediaShield RAID BIOS. Supports one volume per
array. Supports configurations: RAID0 (2+ disks), RAID1 (2 disks), RAID5
(3+ disks), RAID10 (4+ disks), SINGLE (1 disk), CONCAT (2+ disks).
Configurations not supported by NVIDIA MediaShield RAID BIOS, but
enforceable on your own risk: RAID1 (3+ disks).
- Promise
- The format used by Promise and AMD/ATI RAID BIOSes. Supports multiple
volumes per array. Each disk can be split to be used by up to two
arbitrary volumes. Supports configurations: RAID0 (2+ disks), RAID1 (2
disks), RAID5 (3+ disks), RAID10 (4 disks), SINGLE (1 disk), CONCAT (2+
disks). Configurations not supported by RAID BIOSes, but enforceable on
your own risk: RAID1 (3+ disks), RAID10 (6+ disks).
- SiI
- The format used by SiliconImage RAID BIOS. Supports one volume per array.
Supports configurations: RAID0 (2+ disks), RAID1 (2 disks), RAID5 (3+
disks), RAID10 (4 disks), SINGLE (1 disk), CONCAT (2+ disks).
Configurations not supported by SiliconImage RAID BIOS, but enforceable on
your own risk: RAID1 (3+ disks), RAID10 (6+ disks).
The GEOM RAID class follows a modular design, allowing different RAID levels to
be used. Full support for the following RAID levels is currently implemented:
RAID0, RAID1, RAID1E, RAID10, SINGLE, CONCAT. The following RAID levels
supported as read-only for volumes in optimal state (without using
redundancy): RAID4, RAID5, RAID5E, RAID5EE, RAID5R, RAID6, RAIDMDF.
The GEOM RAID class has no support for RAID level migration, allowed by some
metadata formats. If you started migration using BIOS or in some other way,
make sure to complete it there. Do not run GEOM RAID class on migrating
volumes under pain of possible data corruption!
NVIDIA metadata format does not support volumes above 2TiB.
The following
sysctl(8)
variable can be used to control the behavior of the
RAID GEOM class.
- kern.geom.raid.aggressive_spare:
0
- Use any disks without metadata connected to controllers of the vendor
matching to volume metadata format as spare. Use it with much care to not
lose data if connecting unrelated disk!
- kern.geom.raid.clean_time:
5
- Mark volume as clean when idle for the specified number of seconds.
- kern.geom.raid.debug: 0
- Debug level of the
RAID GEOM class.
- kern.geom.raid.enable:
1
- Enable on-disk metadata taste.
- kern.geom.raid.idle_threshold:
1000000
- Time in microseconds to consider a volume idle for rebuild purposes.
- kern.geom.raid.name_format:
0
- Providers name format: 0 -- raid/r{num}, 1 -- raid/{label}.
- kern.geom.raid.read_err_thresh:
10
- Number of read errors equated to disk failure. Write errors are always
considered as disk failures.
- kern.geom.raid.start_timeout:
30
- Time to wait for missing array components on startup.
- kern.geom.raid.X.enable:
1
- Enable taste for specific metadata or transformation module.
Exit status is 0 on success, and non-zero if the command fails.
The graid utility appeared in FreeBSD
9.0.
Visit the GSP FreeBSD Man Page Interface. Output converted with ManDoc. |